iMac

Update from 10.13.6 to 10.14.6 High Sierra

When trying to update from High sierra 10.13.6 to the newer 10.14.6 I’m getting the message warning, this software can not be supported by this system…

I need 10.14.6 on the iMac to install iMovie..

Click to rate this post!
[Total: 0 Average: 0]

Related posts

administrator passcode

Alex

I am trying to check my gmail on my iMac but it is not loading my new emails that I know exist. When I refresh the screen, the emails still do not load. I know the emails are there because I can see them on my iPad Pro and on my iphone.

Undershmidtther

How do I "flush" (remove permanently) any nonOS personal data before discard or selling my older iMac?

Axel

Leave a Comment