macOS Sierra Search

support for 2010 iMac models

Why won't Apple support older 2010 models. Mine works flawlessly and had since it was acquired.

I have 24 megs memory, using 250GB SSD for system and 1T for spare. Ver 10.12 sierra

I can't afford 1000 to 5000 for newer model. Newer programs require 10.15 system.

I am retired with very limited budget! Come on Apple give us older models a break!

CPU is one of the few enjoyments left to me..

Click to rate this post!
[Total: 0 Average: 0]

Related posts

Prevent file being added to folder if it doesn't contain keyword

Pasha

mac pro 5,1 running 10.11.6: unabLe to find sierra 10.12

Dmitry

Uninstall macOS Catalina

Marina

Leave a Comment