MacBook Pro

External Monitor Display Port/HDMI Issues

So I am using a Acer DM431K 43" 60Hz monitor with my 15" 2018 Macbook Pro

MacBook Specs:

Processor: 2.6 GHz 6-Core Intel Core i7

Memory: 16 GB 2400 MHz DDR4

Graphics: Radeon Pro 560X 4GB

Intel UHD Graphics 630 1536 MB

OS: macOS Catalina V 10.15

I have the monitor connected via a USB-C to Display Port Cord. The brand of the Display Port Cord is "J5 Create," which supports 4k 60Hz displays. For some reason, I cannot get my mac to display on the external monitor. The screen is just black and I cannot use the menu buttons on the tv. The cord works for sure. The monitor shows up in the displays section of my preferences, so it is being recognized, but I cannot get it to work in mirror mode or extended display. Even if I decrease the resolution, I cannot get it to work. I looked in my privacy settings for the display link screen recording option, but since I am not using a display link dock, that doesn't really help. I have changed my monitor to DP 1.2 as well, and this did not help. The cable is DP 1.2 compatible as well.

When I connect my mac to the the HDMI port in my VAVA dock dongle I can get picture, but I cannot get the monitor to display at 60Hz, only 30Hz despite using a high speed HDMI cable. I eventually was able to select 4k 60Hz within the display preferences on my mac with the HDMI cable, however when I display the refresh rate number using my screen in the top right, it doesn't go beyond 30Hz, even when I change the overdrive mode to Extreme on the monitor. I am really irked by this because when I use this monitor with the HDMI chord, there is an input lag of about 2-4 frames. I edit video, and the display of videos is delayed these 2-4 frames when listening to the audio. If I open the file on another computer, or on the native screen, the audio is synced perfectly. I figure that running a display port at 60Hz will improve monitor performance due to increased bandwidth from the display port. Can anyone please help! I have been trying to figure this out for hours… Even if I am wrong in assuming the the use of the display port will increase performance of the monitor, I am getting really frustrated with the inability to use the display cord regardless.

I have tried all the solutions within the support page linked by apple:

https://support.apple.com/en-us/HT201177

However, none of them have worked.

I have also tried resetting NVRAM as well as starting up in safety mode with no luck.

If anyone has a solution to this issue, I would greatly appreciate a response. I am really hoping there is a fix and it 's not just some kind of bug with OS Catalina. I attempted to be as through as possible with my issue, so if anyone has any other questions, I will be happy to answer them to the best of my abilities. Anyways, thank you all in advance for reading and for any and all replies.

Sincerely,

Nota4rizzle

Click to rate this post!
[Total: 0 Average: 0]

Related posts

antivirus for macbook pro

Maxim

how is the support going to be in future for intel devices

Axel

MacBook Pro display

Andrey

Leave a Comment