iPod touch

Ipod touch (4thgen)can't support basic apps

I have a 4th gen ipod touch and I cant get mainstream apps to work like pandora and Netflix. The ipod can't support the app. What about fixing that?

Click to rate this post!
[Total: 0 Average: 0]

Related posts

iPod touch

Maxim

So my iPod touch (6th generation) updated to iOS 12.4.4 today, and I’m wondering if that is the last update for this model?

Bobby

I-Pod help please

Bobby

Leave a Comment